Connecting MSPbots with Kaseya VSAX gives you access to the latest automations and innovative dashboards for more efficient and unified IT management. Use this article to configure your Kaseya VSAX integration with MSPbots.
Prerequisites
- A Kaseya VSAX account with server administration privileges
- Admin permissions in MSPbots
How to set up the Kaseya VSAX integration
1. Obtain the required field values when connecting to Kaseya VSAX integration
- Log in to Kaseya VSAX as a server admin.
- On the menu, navigate to Server Admin> Overview.
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Copy the value in the Name to your PC. You will need this for the Server Name field when connecting to Kaseya VSAX integration.
- On the menu, navigate to Configuration > API Access.
- Click Create Token.
- Fill in the required field Name, fill in the remaining parameters as needed, then click Next.
The authentication for the Name field is case-insensitive. For example, "MSPBOTS" and "mspbots" will be recognized as the same token name.
- Click Edit permissions to configure the required field permissions.
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Select the following API permissions, then click Confirm.
- Get All Devices
- Get Assets
- Get a Specific Device
- Get Assets for a Specific Device
- Get Environment Information
- Get Antivirus Status
- Get Device Custom Fields
- Get All Notifications
- Get All Organizations
- Get All Sites
- Get All Tasks
- Next, click Create.
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The Token Generated window appears with the Token ID and Token Secret. Copy these values.
The Token Secret appears only once. Ensure you have a copy saved in a local folder. - Select the checkbox for I confirm that I saved my Token Secret code, then click Accept.
2. Connect to Kaseya VSAX Integration
- Log in to MSPbots as an administrator and navigate to Integrations.
- Search for Kaseya VSAX and click it to open the connection settings.
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Fill in the following fields:
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Click Save and Sync.
Known issues
1. 404 NOT_FOUND
Your Kaseya VSAX integration has encountered a 404 NOT_FOUND error. And the following API endpoints in the Kaseya VSAX integration are unable to successfully sync data.
- Kaseya VSAX Assets
- Kaseya VSAX Devices
- Kaseya VSAX Environment Information
- Kaseya VSAX Notifications
- Kaseya VSAX Organizations
- Kaseya VSAX Sites
- Kaseya VSAX Tasks
Possible causes
- The API functionality in Kaseya VSAX has not been enabled.
- The API permissions set in Kaseya VSAX are not enough.
Solutions
- Log in to your VSAX 10 instance.
- Open a new tab and add /api to your V10 URL to check if the API functionality is enabled. For example, xxx.xxx.xxx/api/.
- If you cannot access the API page or if the page you enter is different from the sample screenshot, it means the API is not enabled. Please contact Kaseya's official technical support to enable your API functionality.
- If you can access the API page and it matches the sample screenshot, it means it is enabled. Please proceed to the next step.
- Please go to Step 1.8 to check if you have set all permissions.
- If not, please refer to Step 1.8 to set all permissions.
- If yes, but your issue persists, please submit a request to our Support team.