N-able N-central offers complete network visibility for on-premise or cloud-based networks. It enables you to map client networks, deploy templates, and use automation policies. Integrating N-central with MSPbots provides real-time notifications and BI automations, leading to better IT management. This article shows the step-by-step guide for connecting N-able N-central to MSPbots.
Prerequisites
You must have the following to establish a successful connection:
- Active N-able account
- N-able Benchmarking license
- Admin role and permissions for setting up the integration
Setting up the N-able N-central integration
The following procedure requires admin rights.
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Create an API-only user and turn off Two-Factor Authentication.
- Set the default administrator role.
- Set the default administrator group.
- Select MFA Not Required.
- Select API-only user.
- Scroll down and click Save.
- (Optional) If you require Warranty Expiry Date information for your device,
- Reach out to N-able N-central technical support to authorize and activate the Warranty Expiry Date feature on your N-Central server.
- Reactivate your N-Central server by yourself.
- Upon completion, MSPbots will automatically synchronize the Warranty Expiry Date information for your device.
For further details, see How to get Warranty Expiry Date from DeviceGet API call to N-able N-central API using SOAP calls.
- Set the default administrator role.
- Log in to the MSPbots app and go to Integrations.
- Search for N-able N-Central and click it to open the configuration settings.
- In the API URL field, enter <server address>, where <server address> is the FQDN or IP address of your N-able N-central server.
Remove all the trailing slashes from the FQDN or IP. Example: If the URL is http://Your_FQDN_or_IP/dms2/servicexx/Servexxx?wsdl, use http://Your_FQDN_or_IP -
Enter the User Name and Password of the API-only user.
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Click Save And Sync.
Known issues
1. Error "Authorization failed"
The error "Authorization failed" appears on the N-able N-central integration in the MSPbots app.
This is possibly caused by an inactive or disabled user status in N-central. To resolve this, contact your administrator and ensure that your status is active. Once you confirm that your account is active, reconnect and authorize connection to MSPbots again.
2. Error "Unable to validate UI session"
An API status for the N-able N-central Integration has failed with the error java.lang.reflect.InvocationTargetException: Unable to validate UI session.
Possible Causes
This error is due to an expired password, which happens every 90 days by default.
Solutions
- Reset your N-able N-central password.
- Reauthorize MSPbots successfully, see the Setting up the N-able N-central integration section.
- Due to the data volume and API rate limiting, wait for 1-3 days until the next synchronization cycle is completed. The cache will be automatically refreshed when the next sync cycle begins, and the synchronization will run normally.
- If the issue persists, please submit a request to our Support team.