How to set up the Cisco Umbrella integration
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Create the Umbrella API Key and Key Secret. Follow the steps on Cisco's Add Umbrella API Keys page.
Note and save the API Key and Key Secret right away. For security reasons, Umbrella displays the keys only once, If lost, there is no way to retrieve the keys.
- Next, go to the MSPbots app and navigate to Integrations.
- Find Cisco Umbrella and click it to open the settings.
- Enter the API Key and Key Secret.
- Click Save and Sync.
- Test your connection. If you encounter an error, check if the Cisco Umbrella account you used to log in has the correct credentials.
Known issues
Issue Description
The following API status for the Cisco Umbrella integration has failed with the error The application has encountered an error.
- APPLICATION-CATEGORIES-SYNC
- APPLICATION-SYNC
- PROTOCOLS-SYNC API
Please confirm whether you need to use the data from the three APIs. If you do not require them, please inform your MAPbots contact, and we will cancel the synchronization of the three APIs, so you will no longer see the three APIs or the error.
Possible Causes
- This may be because your current DNS Monitoring license is a legacy one that does not support Application Discovery/Control.
- The API Key and API Secret you used to authenticate Cisco Umbrella in MSPbots should belong to the end customer, while the ones you may have used for authentication could belong to your MSSP account.
Solutions
- Review your current package here - Cisco Umbrella Package Comparison to see if your DNS Monitoring license supports Application Discovery/Control.
- If it does not support it, please upgrade your DNS Monitoring license.
- If you encounter issues during the upgrade, please contact the Cisco Umbrella technical support.
- If the problem persists after the upgrade, please perform Step 2.
- If it is supported but the issue still exists, please proceed to the next step.
- If it does not support it, please upgrade your DNS Monitoring license.
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Create a new API key and API secret belonging to the end customer and authenticate it in MSPbots.
- Find your Organization ID.
- Go to the Customer Management tab in your MSSP dashboard.
- Hover over the your name to see the Organization ID in the bottom left corner of your browser.
- Alternatively, click the dropdown arrow and find the Organization ID under the Deployment Parameters section.
- Create a new API key and API secret under your Organization ID.
- Navigate to Admin > API Keys.
- Click on the API Keys tab, and then click Add in the upper right corner.
- Create a new API Key and API Secret.
- Use the new API Key and API Secret to re-authenticate in the MSPBots system, see How to set up the Cisco Umbrella integration.
- Find your Organization ID.
- If the issue still persists, submit a request to our Support team.