Selecting multiple filters does not show tickets in Next Ticket and displays the following message after clicking Preview:
No tickets available. Try changing your filter conditions to proceed.
Removing one or two filters, however, shows the tickets.
Root Cause
The error appears when multiple filtering conditions are set up for Next Ticket, resulting in a long URL that exceeds the ConnectWise API limit. In the example below, the multiple companyIds and statusIds used exceeded the limit when the parameters were concatenated, and caused the error.
Resolution
As URLs become lengthy, they no longer remain user-friendly and readable by users, and may lead to compatibility issues with different servers and configurations. We recommend using the multiple filters logic setting for ticket prioritization.