The user updated the ticket owner in the ConnectWise Resource & Schedule pod but the webhook did not send this modification to MSPbots. The fields owner_id, owner_name, and owner_change_time show [NULL].
Root cause
Webhook is triggered every time tickets are updated. Updates on the ticket's Resource & Schedule pod are saved in ConnectWise, however, edits on this pod are not counted as ticket edits. Only modifications considered ticket edits trigger the webhook and push updates. As a result, MSPbots did not receive the update.
Resolution
Users must click the Save button on the ticket to trigger the data push from ConnectWise.