Introduction
There are a few factors that might lead to some widget data discrepancies within the app.
Prerequisites
Before you proceed, make sure that you are logged in to the MSPbots app as an administrator.
Symptoms
- Output from widget does not capture all data.
- Missing records from widget drill through.
- Records are limited to a fixed number of rows regardless of any updates.
- On a Card Number widget type, output shows 0s even if the correct measure was already selected from the Widget Builder > Config tab.
Possible Causes
- Row limit is set on the widget or layer.
- Widget filter(s) not properly set.
- Dataset layer is not set from the widget.
- Conflict with dimensions and Card Number widget type.
Solutions
Remove the Row Limit.
- Navigate to Widgets.
- Find the widget and click it to open.
- Click
to the Dataset tab.
- Click on the Row Limit field then clear it via the Backspace / Delete button on your keyboard.
- Click Apply to save the update.
Update the widget filter(s).
- Navigate to Widgets.
- Find the widget and click it to open.
- Click
to the Dataset tab.
- Access the Data Source / Layer settings via the ellipsis icon then click Edit.
- Review the Filter section to see if you need to add, remove, or modify based on your requirements.
- Click Save.
- Click Apply to save the update.
Select a dataset layer based on your requirements.
- Navigate to Widgets.
- Find the widget and click it to open.
- Click
to the Dataset tab.
- Access the Data Source / Layer settings via the ellipsis icon then click Edit.
- Click the
icon.
- Select a dataset layer based on your requirements.
- Click Save.
- Click Apply to save the update.
Remove the layer dimension.
- Access the Data Source / Layer settings via the ellipsis icon then click on Edit.
- Click
to remove the dimension.
- Click Save.
- Click Apply to keep the settings.
Contacts
If your issue remains unfixed, submit a request to our Help Center for help.